Post Reply 
Howto Disable header filter "Content-Type: 1 Manage listed Types" through List
Mar. 13, 2012, 12:47 PM (This post was last modified: Mar. 13, 2012 02:00 PM by fpout.)
Post: #1
Howto Disable header filter "Content-Type: 1 Manage listed Types" through List
Hi,

On some forum's reply message box, in order to have the bold-underline-center-code-... buttons work in the message editor, I need to inactivate filters:

"Content-Type: 1 Manage listed Types 07.11.08 [sd] (d.r) (In)"

and

"Content-Type: 3c Fix acc. to File Extension 09.02.28 [srl sd] (d.1) (In)"

I have been able to manage for the second with keyword "a_cont_typ."by this entry in Exceptions-U:

Code:
([^.]++.|)softmaroc.org        $SET(1=adpath:0.i_ssl_h:0.a_jsprop.)$SET(0=a_cont_typ.)

But I cannot find how to do it for the 1st header filter ("Content-Type: 1 Manage listed Types 07.11.08 [sd] (d.r) (In)")

Is there a way to do it through Exceptions-U ? I tried "$SET(1=cont_typ_b:2.)" without success.

______________________

EDIT : This is funny:

Instead of unticking Header filter "Content-Type: 1 Manage listed Types 07.11.08 [sd] (d.r) (In)", I alternatively get the buttons working by:

- Clic on Prox Menu triangle -> tick "[UA & Referrer[/b]" --> Session

... then it works just as when I untick "Content-Type: 1 Manage listed Types 07.11.08 [sd] (d.r) (In)"

.
Add Thank You Quote this message in a reply
Mar. 13, 2012, 07:51 PM
Post: #2
RE: Howto Disable header filter "Content-Type: 1 Manage listed Types" through List
I think something like

Code:
## force specified content-type                 $SET(hRealCT=IncEx: cont/type)
## ----------------------------------------------------------------------------

is required. However, let's examine the problem.

The site is sending a content type header, "application/javascript", that the Proxomitron does not filter by default. So the set changes it to "text/javascript", which is filtered by default.

So when you disable "Content-Type: 1 Manage listed Types 07.11.08 [sd] (d.r) (In)", you are not filtering the site's "application/javascript" files.

This may be just fine and if it is you could add a entry to bypass some or all of the site's js files.

If you enable "HTML Debug info", clear the browser's cache, and click "Show ?? Scripts" in the set's menu, you may be able to see what the filters are breaking.

HTH
Add Thank You Quote this message in a reply
Mar. 14, 2012, 02:46 PM
Post: #3
RE: Howto Disable header filter "Content-Type: 1 Manage listed Types" through List
Add Thank You Quote this message in a reply
Mar. 14, 2012, 03:20 PM
Post: #4
RE: Howto Disable header filter "Content-Type: 1 Manage listed Types" through List
(Mar. 14, 2012 02:46 PM)fpout Wrote:  By the way, how comes sometimes setting the keyword doesn't work when un-ticking the filter does work ? It's not the first time I fall upon that.

Aren't you adding to the wrong variable.

Try

Code:
([^.]++.|)softmaroc.org        $SET(1=adpath:0.)$SET(0=a_cont_typ.i_ssl_h:0.a_jsprop.)
Add Thank You Quote this message in a reply
Mar. 19, 2012, 09:43 PM
Post: #5
RE: Howto Disable header filter "Content-Type: 1 Manage listed Types" through List
.
JJoe, you're right, it works nicely this way, with "i_ssl_h:0.a_jsprop." put in "$SET(0=" .

I suppose I am doing the same inversion each time Exceptions-U doesn't work the same as un-ticking a filter, no ?

Anyhow, many thanks to you.
.
Add Thank You Quote this message in a reply
Mar. 19, 2012, 10:54 PM
Post: #6
RE: Howto Disable header filter "Content-Type: 1 Manage listed Types" through List
(Mar. 19, 2012 09:43 PM)fpout Wrote:  .

I suppose I am doing the same inversion each time Exceptions-U doesn't work the same as un-ticking a filter, no ?

Anyhow, many thanks to you.
.

It's one of the possibilities.

Have fun
Add Thank You Quote this message in a reply
Post Reply 


Forum Jump: