Post Reply 
Google problems on Opera and Iron/Chrome
Oct. 29, 2010, 09:48 AM (This post was last modified: Oct. 29, 2010 09:50 AM by Mele20.)
Post: #1
Google problems on Opera and Iron/Chrome
I have been using Scroogle for a long time exclusively but as of today Scroogle is now garishly highlighting every word in the search term. Makes it very difficult to read the results with all the ugly distraction and weird colors (a different very garish color for each word in the search term). I am also suddenly getting 100 results on Scroogle from search on the address bar and I never had more than the default 20 until today. That's very nice but not the highlighted terms.

I switched to using Google on Opera 10.63, and Opera 11, and I get 11 results instead of 100, and that horrible Google Suggest junk is back! But I do have the Proxo Google toggle switch for the yucky left side panel and the panel is off by default. That part is good.

Do I have to import KyeU's filter to stop Google Suggest? I assumed that would be a standard part of the latest filter set.

On Safari for Windows ver 5.2, I get 100 search results with Google (but get the google suggest junk). I also have the toggle switch.

On Iron/Chrome, I get only 11 search results for a common search term! And some are images and I didn't search for images. I get the awful google suggest. I have the toggle switch.

So, what is with Opera and Iron only giving me a very few search results when using Sidki's latest filters?

None of the Google searches on any browser highlight the search words. So, if there is a way I can get Scroogle to not highlight them then I will use Scroogle again. Can Proxo filter out the search term highlights in Scroogle search?

Edit to add that I do not use any of the Google theme filters but all other Google filters are enabled.
Add Thank You Quote this message in a reply
Oct. 29, 2010, 10:42 AM
Post: #2
RE: Google problems on Opera and Iron/Chrome
if you BLOCK cookies by default (as i do), you will get a limited number of results at Google...

Google is "trying" to FORCE us to allow their [email protected] cookie...

sidki's set by default sets cookies as "session only", so Google's cookie is still being used, it's just wiped clean when you close your browser...

Google no longer, though they used to, allows us to set a ":NR=100" via a FAKED COOKIE to control how many results we receive...

the ":NR=100" works if you allow a session-only cookie (or a "normal" cookie, of course)... but it does not work if you BLOCK cookies and fake cookie contents...


there IS a "workaround"...
in your browser's "search box", set its search string to append "&num=100" (without the quotes) to your search query...

as an example, my GreenBrowser search string is http://www.google.com/search?q=%u&num=25&hl=en&lr=lang_en&safe=off where "%u" becomes whatever i enter into the search box...
Add Thank You Quote this message in a reply
Oct. 29, 2010, 12:49 PM (This post was last modified: Oct. 29, 2010 12:53 PM by Mele20.)
Post: #3
RE: Google problems on Opera and Iron/Chrome
Ahhh....I had no idea Google was doing that. But it doesn't surprise me really. Yeah, I thought we could still set the "NR-100" via the fake cookie Proxo sends.

OH! Are you saying that Proxo no longer even sends a fake cookie? That the real Google cookie is now being accepted? I uncheck Sidki's setting for making all cookies session only. I want some (albeit very few) permanent cookies...like here for instance. So, I am now getting a REAL google cookie? Through Proxo? I noticed that I was prompted to accept a Google cookie on each browser and that did not used to happen. I attributed it to not having used Google in so long that my browsers probably no longer had a record of my denying Google cookies and telling the browsers to not ask again but automatically deny.

If I understand you correctly though, I was actually getting that cookie prompt because Proxo no longer sends a fake cookie that satisfies Google? UGH. But I guess no real harm done as I told the browsers to deny google's request to set a cookie and since Proxo's cookie doesn't work anymore, I got that pathetic number of results instead of the 100. What shits Google has become. And where was I when there must have been discussion about this here? I guess I didn't pay attention because I was happy with Scroogle.

Thank you for the workaround. I'll use that. But I am better off using Scroogle if I can get it to not highlight every search term and, what is worse, to highlight with a different color for each word in the search term.

EDIT: AH! And I got the 100 for Safari search because with Safari you cannot deny first party cookies (main reason I very seldom use Safari ...otherwise I like it but not if it compromises my privacy as it does).
Add Thank You Quote this message in a reply
Oct. 29, 2010, 02:26 PM (This post was last modified: Oct. 29, 2010 02:28 PM by ProxRocks.)
Post: #4
RE: Google problems on Opera and Iron/Chrome
a google discussion never arose here, most people aren't as strict with their cookies as you and i...

sidki is "session only" by default and the NR=100 does "catch" AFTER google drops its cookie and at which point Proxo "fakes" the contents 'within' that dropped cookie...

but if you do NOT let that cookie get dropped in the first place, then sidki's set will give you only 10 search results (i count 10, did you say 11?)...


Proxo is only faking the "contents" of the google cookie, it isn't "blocking" google's cookie by "replacing" it with a fake one (with sidki defaults)...

note that a truly "faked" cookie will have the text "cookie" (in advanced mode) at the bottom of the page BUT the text will have a line through it!... if there is no line through it, then the cookie exists on your harddrive and you are merely faking CONTENTS within that REAL cookie...

BLOCK cookies by default, use the num= trick, and you will NOT have a "real" cookie whereby you only fake the 'contents' of that "real" cookie...
Add Thank You Quote this message in a reply
Oct. 29, 2010, 03:49 PM
Post: #5
RE: Google problems on Opera and Iron/Chrome
(Oct. 29, 2010 09:48 AM)Mele20 Wrote:  So, if there is a way I can get Scroogle to not highlight them then I will use Scroogle again. Can Proxo filter out the search term highlights in Scroogle search?

Of course Proxomitron can do it for you.

Code:
[Patterns]
Name = "Scroogle Remove Highlighting"
Active = TRUE
URL = "www.scroogle.org/cgi-bin/"
Limit = 128
Match = "<b style="background-color:*>\1</b>"
Replace = "\1"
Add Thank You Quote this message in a reply
Oct. 29, 2010, 06:56 PM
Post: #6
RE: Google problems on Opera and Iron/Chrome
For several days, I've been seeing many differently coded google pages.
Sometimes everything works as hoped and sometimes not.
Add Thank You Quote this message in a reply
Oct. 29, 2010, 08:00 PM
Post: #7
RE: Google problems on Opera and Iron/Chrome
i've seen the same, change the word order of the search phrase and things look ok again...

i haven't tracked down what's happening just yet, i figured i'd wait to see if google stops tickering around with the coding...
Add Thank You Quote this message in a reply
Oct. 30, 2010, 02:13 PM (This post was last modified: Oct. 30, 2010 02:20 PM by sbk.)
Post: #8
RE: Google problems on Opera and Iron/Chrome
you could use a stylesheet to clear scroogle's highlighting. This is a yellow word in view-source:
<b style="background-color: rgb(255, 255, 102);">HIGHLIGHTED</b>
this line in a scroogle css file should work
b{background-color:#fff!important;}
___________
i don't get google suggest, but haven't deliberately done anything to prevent it...
_______
the num=100 problem.
use header filter add to search url:
&as_qdr=all&num=100

just &num=100 worked until a couple months ago, now google wants &as_qdr=all&num=100

adding the newer tbs=qdr:w4 instead of the old as_qdr=all didn't work when i tested for solution.
i think i tried tbs=qdr:all
which still did not "force" the num=100, but google may not accept "all" value for tbs=qdr:
_______
google cookies off. also js off on google images and some lesser searches (video, and maps, IIRC)
Add Thank You Quote this message in a reply
Oct. 31, 2010, 12:38 PM
Post: #9
RE: Google problems on Opera and Iron/Chrome
(Oct. 29, 2010 03:49 PM)whenever Wrote:  
(Oct. 29, 2010 09:48 AM)Mele20 Wrote:  So, if there is a way I can get Scroogle to not highlight them then I will use Scroogle again. Can Proxo filter out the search term highlights in Scroogle search?

Of course Proxomitron can do it for you.

Code:
[Patterns]
Name = "Scroogle Remove Highlighting"
Active = TRUE
URL = "www.scroogle.org/cgi-bin/"
Limit = 128
Match = "<b style="background-color:*>\1</b>"
Replace = "\1"

Thank you! Smile! That works great. Now I just have to hope that Google continues to allow Scroogle to scrap. That wa a close call earlier this year for Scroogle. The more people that use Scroogle the more likely Google will shut them down which is sad.
Add Thank You Quote this message in a reply
Oct. 31, 2010, 01:04 PM
Post: #10
RE: Google problems on Opera and Iron/Chrome
(Oct. 29, 2010 02:26 PM)ProxRocks Wrote:  but if you do NOT let that cookie get dropped in the first place, then sidki's set will give you only 10 search results (i count 10, did you say 11?)...


Proxo is only faking the "contents" of the google cookie, it isn't "blocking" google's cookie by "replacing" it with a fake one (with sidki defaults)...

note that a truly "faked" cookie will have the text "cookie" (in advanced mode) at the bottom of the page BUT the text will have a line through it!... if there is no line through it, then the cookie exists on your harddrive and you are merely faking CONTENTS within that REAL cookie...

BLOCK cookies by default, use the num= trick, and you will NOT have a "real" cookie whereby you only fake the 'contents' of that "real" cookie...

Maybe I miscounted the number of search items returned...but one search I thought I counted 11 and on a different search 13..rather strange the inconsistency.

I thank you for the detailed explanation of how Proxo's fake Google cookie works. I guess I never really understood the details before. But I don't think, in the past, it was tied to using Sidki's default set all cookies to session filter. I never have used that filter yet Proxo used to deal with the Google cookie and I would get the 100 results. But in Fx, Opera, etc I never saw any Google cookie because I blocked Google cookies that tried to set via my browsers. I don't know...maybe the Proxo cookie was never in effect and I was getting the 100 results even though I blocked Google cookies in the browsers and then Google decided to tighten the screws on folks.

I seldom use Sidki's advance mode. I use the Standard mode. But after your explanation of what I would see regarding cookies and the line through the cookie text at the bottom of the page (I have never seen a line but then I have been using standard mode and i don't always examine that anyway because generally my browsers block almost cookies), maybe I should switch to Advanced mode for a bit. I think I just THOUGHT google was using Proxo's cookie and in reality no cookie was set and then Google changed to be more strict and actually enforce the use of cookies and so when I denied them after the change then I started seeing the 10-13 results instead of 100.

I had trouble properly adding that text to the search string in Opera. Plus, I cannot do a Google search via the address bar but can a Scroogle one. I guess that is because I am blocking google cookies and not letting the Proxo one kick in because I disabled the filter to set all cookies to session. The only browser that will do a Google search via the address bar is Safari for Windows and I think it does because you cannot block first party cookies on it.
Add Thank You Quote this message in a reply
Post Reply 


Forum Jump: