The Un-Official Proxomitron Forum

Full Version: Linux version installation problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2

[r4]

Does the downloadable version of BFilter for Linux consist only of GUI? I'm asking because it seems to install (using autopackage), but there's no way it can be run. Long story short, after the installer finishes, the GUI icon appears in the tray notification area for a blink of an eye, then it disappears. And there's no menu item to run it again.

Sure, I could use BFilter installed from Ubuntu repositories, but they contain older version (like 1.0.6, I guess).

Thanks in advance.

BTW, does anyone conducted any test to show the real difference between pages BFiltered and pure versions of them? My urlfilter.ini in Opera is so full of different patterns that I hardly notice the differences, besides the fact that pages take longer to load (using aforementioned version 1.0.6 form Ubuntu repo), but that's how it's supposed to work I guess. Smile!
The Autopackage version only contains the GUI, not the daemon. The GUI doesn't require the daemon, so it should fit your needs. The menu entry should be installed somewhere under Internet (Internet -> Other -> BFilter Web Proxy in my case). It's it's not installed - that's probably a bug in Autopackage. You may want to try a newer version of it (sorry, I don't remember how to upgrade it).
As for the tray icon appearing for a moment and then disappearing, I don't know. Autopackage installer should not launch programs it installs.

As for page loading speed, I don't think anyone has done any measurements, but it should have improved since version 1.1, which introduced caching of external scripts.

[r4]

jart, thank you for quick reply.

I supposed that the package contains only GUI and no daemon, and began to wonder where am I going to get the binary for the service. I'm not into compiling stuff, so I guess I'll use older version that's available in Ubuntu repositories until the newer version get its development done. Hopefully, with the Flash version reporting issue corrected. Smile!

I use GNOME and the installer doesn't put any icon on the menu (it should be Applications -> Internet I guess) nor allows me to run anything like bfilter-gui from the command line. Strange, but I'm so new to Linux environment I don't even know where to start investigating this.
Quote:... nor allows me to run anything like bfilter-gui from the command line
It does. If you installed it system-wide (providing the password when asked), then you should be able to just enter bfilter-gui at the command prompt. Otherwise, the binary will be located in $HOME/.local/bin/bfilter-gui

[r4]

jart Wrote:It does. If you installed it system-wide (providing the password when asked), then you should be able to just enter bfilter-gui at the command prompt. Otherwise, the binary will be located in $HOME/.local/bin/bfilter-gui

Right this very moment I've uninstalled GUI version 1.0.6 provided by Ubuntu maintainers (removing packages bfilter-gui and bfilter-common) and installed the one downloaded from BFilter homepage. First of all, it didn't ask for admin's password, but that's no problem since I'm the only user around here. Smile! Installer told me it put a menu icon under (Internet, GTK+) but there's nothing that even resembles BFilter among those few menu options I have.

What's more, running
Code:
whereis bfilter
returns
Code:
bfilter: /etc/bfilter
, while executing
Code:
whereis bfilter-gui
(which is supposedly installed already) returns nothing at all.

The directory you mentioned contains only the files belonging to the autopackage installer. Listing of ~/.local/bin/:
Code:
~/.local/bin$ ls
autopackage-frontend-gtk  autopackage-launcher-gtk-nautilus-wrapper  package
autopackage-launcher-gtk  autopackage-manager-gtk
and they're all executables!

I'm losing my faith already. Maybe I've overlooked something? I hope soon GetDeb will assemble nice little .deb package for me to use Smile!

Anyway, thank you, jart, you're great. Hail
It looks like BFilter autopackage didn't install successfully. Most likely a bug in Autopackage is to blame here.
You can try installing it from the command line.
Code:
cd Desktop
./bfilter-gui-1.1.1.x86.package
If it tells you to use "package" instead of running it directly, do:
Code:
package install ./bfilter-gui-1.1.1.x86.package
Also try uninstalling Autopackage itself before installing BFilter autopackage:
Code:
package remove autopackage autopackage-gtk autopackage-qt

Guest

Okay, I "solved" the problem, however the solution was obvious. The installer reports it cannot read/create a few files, so the idea is to give it root access. The only thing one has to do to install BFilter is to use command
Code:
sudo ~/.local/bin/package ./bfilter-gui-1.1.1.x86.package
after succesfully removing previous installations (or installation attempts). Smile!

Thanks again, jart.

zebul66

sure. if you have a fairly complete filter list in opera you do not really need bfilter.
it is mostly usefull when this list is empty and you don't want to make one.

[r4]

Sorry for reviving such an old topic (I guess it's zombie now, aint' it? "More braaaaains..." comes to mind :P). I've just found newer version of BFilter being available, happily downloaded it's "package" version - planning to do some direct upgrade - and found myself in trouble again.

My pretty well exercised Smile! method desribed above allowed me to install BFilter... but it won't alow me to remove it! Installation of a new version consist simply of removing an old 1.1.1 and installing 1.1.2 instead - as far as I understand what's being done here. The problem is - my system insists that the administrator installed a program and he's the one and only allowed to remove it! I tried "sudo" and switching permanently to root account, still to no avail.

Code:
sudo ~/.local/bin/package install ./bfilter-gui-1.1.2.x86.package
runs pretty graphical installer, which fails. Any attempt to remove it manually fails also. Would you be so kind and post any suggestion regarding this matter? I'm eager to update, however I can wait at least that one day - tomorrow Ubuntu 7.10 will be released.
I would try the following:
Code:
export DEBUGLEVEL=3
sudo ~/.local/bin/package install ./bfilter-gui-1.1.2.x86.package
It should give you more information this way.

I would also try:
Code:
sudo ~/.local/bin/package remove bfilter-gui autopackage-gtk
Maybe even a manual delete of ~/.local

After that, try installing without sudo first, then with sudo.

[r4]

Well, jart, thank you again Smile! I'm not sure whether it's your advice or today's Ubuntu update, but it worked excellent, without any hassle. I just put
Code:
export DEBUGLEVEL=3
sudo ~/.local/bin/package install ~/Desktop/bfilter-gui-1.1.2.x86.package
and it worked just as one'd expect.

I'm now happy user of BFilter v.1.1.2. Thank you again! Hail

[r4]

There is only one more thing that's bothering me... How do i make BFilter autostart without popping up it's window? What I mean is that in my Ubuntu I set Bfilter to be autmatically run at startup. But every time the computer is booted, Bfilter isn't hiding in the tray; instead it displays this small icon in a separate window (which has a associated button on the window bar). After single-clicking it, it disappears (putting an icon whre it should be - into the tray).

Do you have any idea how to get rid of this annoyance?
This happens because BFilter is started before the tray panel has fully initialized. Unfortunately, there is no way to change startup order in the gnome session manager. In fact, all user-made additions are placed at the top of the list.
The solution would be to create a script like this:
Code:
#!/bin/sh
sleep 5
exec /path/to/bfilter-gui
And then launch that instead of launching bfilter-gui directly.

[r4]

Thank you, jart, you're the best. However, your solution doesn't work. Maybe I don't understand something here, so I'll try to explain:
Code:
#!/bin/bash //does nothing at all, it's just a "magic byte"
sleep 120 //yep, that's my value, delays execution for given amount of seconds
exec bfilter-gui //actually runs BFilter (given it's executable is in the current directory
The problem is: whatever period I order the script to sleep for, it doesn't work. What is more, for the reason still unindentified, sometimes BFilter starts twice (sic!), with one copy obviously defunct. (However I guess it's about the way I call bfilter-gui binary, whether it's simple "./bfilter-gui" or "~/.local/bin/bfilter-gui").

To clarify some more, I'd mention that GNOME runs BFilter through "Sessions" menu.

Any ideas?
First, make sure the script you created is executable. Use Right click -> Properties -> Permissions to check and fix that.
Then, I'd suggest specifying the full path to bfilter-gui. Next, 120 second delay is obviously too much.
As for running twice, maybe it's listed twice in Sessions?
Pages: 1 2
Reference URL's