The Un-Official Proxomitron Forum

Full Version: Sudden problem with Google filters in Firefox
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hello all,

Recently, I have problems with the Proxomitron filters for Google in Firefox 15 under Windows 7 32 Bit. I am using the Light Blue Theme and Toggle Left Bar filters, which worked absolutely fine in the past. This changed last week or so, probably after a Firefox update. When I now submit a search, the first result page is ok as usual. But when I click on "Next", the following page lacks the Light Blue Theme and the toggle triangle is gone. The left bar does not show up. I use the same filters in IE9 and everything still works fine there.
Strangely enough, it still works without problems on my other computer in Firefox 15 under Windows XP. I find this quite confusing, but I am still thinking that the latest Firefox version is the suspect.

I am not so well-versed in programming, but I hope that one of you experts can help me.

Attached are screen shots of the first ok result page (1.png), the second messed-up page after clicking Next (2.png) and my Google filters in Proxomitron (3.png).

Best regards
Thomas
Works for me.
Attach the source for a page that does not work and we'll see what we can do.
Great. Here the source text of the page.

(I enter "test" as search term in Google Advanced Search, then I press "Enter", and everything is fine. Then, I click "Next" at the bottom of the page and the resulting page is messed up. And this is its source text in Firefox.)

Thanks!
I think you attached the source for the 'working' first page? After opening it in Firefox 15, I see our expected highlighting and an unlinked "1" at page bottom.
I need 'broken' source, since I haven't managed to reproduce your problem.

Also, your source appears to indicate that you are using Firefox 16 and a dated "User-Agents.ptxt"?

Quote:ncWith: "Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:16.0) Gecko/20100101 Firefox/16.0.9.9"

I'm using a updated User-Agents.ptxt, http://prxbx.com/forums/showthread.php?tid=2034 .
My header is
Quote:"Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0.9.9"
.
Our browsers are seeing different code.

I suggest updating "User-Agents.ptxt" (regardless), test, attach more source, if needed.

Assuming that you are not spoofing the User-Agent, Firefox 16 may have some problems?
Adding
?prx-command=dbug..
to the end of the google address or enabling "HTML Debug info" in the Proxomitron's window may allow you to see the filter hits for "Google Toggle: Left NavBar" and "Google Theme: Light Blue".

HTH Smile!
Another question.

Is there a "#" in the address of the messed up page?
Hi JJoe,

First off all: Many thanks for your friendly efforts!

1. I did indeed attach the source text of the broken page. If I load this source into IE9 for example, everything is displayed well. Only in Firefox, it is messed up.

2. I don't now exactly, when the problem appeared first, but certainly not after I installed version 16. It started in version 15. I thought that it might help to downgrade and downloaded the installer for version 14 from the Firefox FTP site, deinstalled version 15 and installed version 14 instead. The problem remained. During my stay at the Firefox FTP, I noticed that there was already a prerelease of version 16 available and in the vague hope that this would solve my problem, I installed it. But no change. It is all the same in versions 14, 15, and 16. By the way, when I click on any search result on the messed up page, I yield always only error 404 (please see the attached screen shot 404.png).

3. I followed your advice and replaced my User-Agents.ptxt by yours. No change...

4. I opened Proxomitron's log window (at first without the HTML debug option) and this (message log 1.txt) is, what it shows, when the working results page is loading, and this (message log 2.txt) when the broken page is loading. I do not understand too much of it, but I find that entry "RESP 944 : Content-Disposition: Attachment -> Filters off!" curious, that is shown when the messed up page loads. In HTML DEBUG INFO.txt you find, what is displaying in the browser window, when the broken page is loading.

5. One more observation: When I right click on Next on the working (first) search results page, instead of left clicking, chose the option "Copy link target", paste this into the browser's address field and hit Enter, the following page opens in perfectly order. Strange, isn't it?

6. I cannot find any "#" in the address of the messed up page.

7. I did not observe any other problems with proximotron and Firefox, it is only with Google.

If you find out, what is wrong here, you are a real genius. Oh crap, you are a genius anyway!


Thanks a lot and
Best regards
Thomas
And, of course, I tried the option to start Firefox with all add-ons disabled. The problem was still there.
One addition to point 1: I have Firefox 15 on a different machine (Windows XP, although I am not sure, whether the OS matters in this case) with nearly the same settings and add-ons and I haven't the problem there, even with the older User-Agents.ptxt. But that's now really everything I know. Thanks again!
Hey JJoe, it's me again...

I deactivated all Google filters in the Proxomitron filter editor under "Webpage". The problem persists! Means that after I enter a search term on the Google Advanced Search start page, then push Enter and then click on Next on the bottom of the results page, when I click on a search result on this seconf page, I get 404! On the other hand: When I put Proxomitron on "Bypass" instead, everything works perfectly. So, I draw 2 logical conclusions:
1. It must have definitely something to do with Proxomitron, but
2. not with its Web Page section.

Do you agree?
So, could it probably have something to do with the headers section? My head is buzzing...
Ok. I deleted the whole "Headers" section from the configuration file and tried again. The problem persisted (clicking on an rsult on the second results page yields a 404. After restoring the configuration file, I deleted the whole "Patterns" section and suddenly Google worked again. In my opinion, this means that one or more of the filters of the "Web page" ("Patterns") section cause the problem, but not the Google filters themselves (please compare my last posts).

Best
Thomas
you may have ended up "corrupting" your config beyond usability...
ie, for one, you can not delete all of the header filters and have a "usable" config...

i suggest downloading the "most recent" sidki config and re-start from the ground up -
http://prxbx.com/forums/showthread.php?t...4#pid15994

that also will make those of us trying to help you out "on the same page" Smile!
(Sep. 18, 2012 06:18 PM)flyingbeetle Wrote: [ -> ]Ok. I deleted the whole "Headers" section

As ProxRocks say's, some of the filters are required.

I'll guess that you have found an ajax, http://en.wikipedia.org/wiki/Ajax_(programming) , Google page that does not use a "#" in the address.

The "undefined" in the 404 for www.google.com/undefined makes me think there is a broken script on the refering page.

This
Quote:RESP 944 : Content-Disposition: Attachment -> Filters off!
Quote:Content-Type: application/json; charset=UTF-8

for

Quote:+++GET 944+++
GET /search?q=test&hl=en&lr=&safe=off&as_qdr=all&complete=0&prmd=imvnsl&ei=iZFYUNXFKZHEtAahm4DIDA&start=10&sa=N&bav=on.2,or.r_gc.r_pw.&fp=a4368808566a67d2&biw=978&bih=577&tch=1
&ech=1&psi=iZFYUNXFKZHEtAahm4DIDA.1347981705304.3 HTTP/1.1
Host: http://www.google.com

is the suspect ajax response that the sidki set does not filter by default.

The question is, where is the 'use ajax' trigger hiding...

Are you signed in to Google?
There are parameters in that address that I don't remember.

What happens after adding this filter,

Code:
[HTTP headers]
In = FALSE
Out = TRUE
Key = "! : JUMP: Google RemovedParameters (out) (12.08.31) [ADD]"
URL = "www.google.[^/]+/search\?&(*(^(^\?))(\3([\?\&](as_[^=]+|q|tbm|gbv|tbs|start|safe|tbo|num|complete|prmdo|esrch|biw|bih|sout|nfpr|lr|cr|prx-command)=[^\&]+)\#$SET(removed=$GET(removed)\3))+{1,*}(?+)\3$SET(removed=$GET(removed)\3)$TST(removed=?*)$SET(kept=\@)$TST(kept=[\?\&]\6)$URL(\5\?)$JUMP(\5?\6)|$SET(removed=)$SET(kept=)!(^))"
Replace = "$LOG(R$DTM(c):RemovedParameters:$GET(removed))$SET(removed=)$SET(kept=)"

It removes unlisted parameters from the google address. The listed parameters are in
(as_[^=]+|q|tbm|gbv|tbs|start|safe|tbo|num|complete|prmdo|esrch|biw|bih|sout|nfpr|lr|cr|prx-command).

HTH
And what happens after you add

Code:
www.google.*/[^/]++\?$SET(sUserFn=§c&&c.getElementById§a&&a.getElementById§)$SET(sUserFnR=!)

to Exceptions-U?
Hi JJoe,

I added your above header filter ("! : JUMP: Google RemovedParameters (out) (12.08.31) [ADD]") and since then everything runs like clockwork, better than ever before! That's sorcery beyond my comprehension! Thank you so much!

No, I am not signed in to Google, since I prefer somewhat more privacy and this is also the reason, why I use and love Proxomitron. Should I now go on and try to add the expression that you proposed in your most recent message to Exceptions-U, or is that obsolete, as I already have a working solution? True to the motto: "Never change a working system"!

Many thanks again for your help!
Pages: 1 2
Reference URL's