The Un-Official Proxomitron Forum

Full Version: bfilter wont connect (post Privoxy install)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi, I'm new to Proxys, I tried out Privoxy and it worked fine but was too time consuming to edit and customize so I decided to try out bfilter. Ever since I installed it I can't get it to work.

My set up is Windows XP Service Pack 2 with Google Chrome 4.1.249.

I quit Privoxy, although I haven't uninstalled it yet, and set up bfilter as described in the guide for Chrome. I have 127.0.0.1 and 8080 in my Windows LAN settings. bfilter had the port set to 8118 everywhere when I installed it. I went through all the tabs in "advanced configuration" and "forwarding" and corrected it to 8080 but still can't connect to the web with bfilter as proxy.

I'm out of ideas? Thanks for any help.

Code:
[global]
; listen_address = host:port
; The address to bind the proxy to.
; An empty host will cause binding to all IPs of that computer.
; Several listen addresses separated with a comma may be specified.
; Example: listen_address = 192.168.0.1:8000, 10.0.0.1:9000
listen_address=127.0.0.1:8080

; client_compression = yes | no
; If set to 'yes', all the textual data (Content-Type: text/*) will
; be compressed before sending it to the client.
; This option can be useful if you are on a slow connection and you set up
; bfilter somewhere on a fast connection.  In other cases, setting this
; option to 'yes', will just introduce additional latency to the loading
; process.
client_compression=no

; ad_border = rrggbb | none
; The default behavior is to draw borders around removed ads.
; You may want to change the border color or turn the borders off.
ad_border=676767

; page_cleanup = off | safe | maximum
; Allows you to remove ads completely, as opposed to substituting them with
; a clickable replacement image.  When set to "maximum", it worsens ad
; detection accuracy.  This may result in both false-positives and
; false-negatives.  When set to "safe", it doesn't worsen ad detection
; accuracy, but some ads won't be removed.  For such ads, you can still
; use "ad_border = none" to make them invisible but still clickable.
page_cleanup=off

; tray_icon_animation = yes | no
; Enable or disable the tray icon animation.
; The animation indicates traffic is going through BFilter.
tray_icon_animation=yes

; max_script_fetch_size = size_in_kilobytes
; Limits the size of external scripts that bfilter fetches.
; Large script are not likely to be used to serve ads.
max_script_fetch_size=60

; max_script_eval_size = size_in_kilobytes
; Basically just a protection against compressed scripts decompressing to
; very large sizes.
max_script_eval_size=180

; max_script_nest_level = number
; Limits nesting level of scripts. The reasoning is the same as for
; max_script_fetch_size. A smaller value like 3 will make bfilter faster,
; while a bigger value like 9 will make it detect more ads. The author
; has never seen an ad that is generated at levels higher than 6.
; Setting this value to 0 will disable script processing at all.
max_script_nest_level=6

; save_traffic_threshold = size_in_kilobytes
; Sometimes bfilter needs to download an image or a flash file to determine
; if it's an ad or not. Since bfilter tries to do everything on the fly,
; it usually knows the answer before the whole file is downloaded. At that
; time it checks how much data is left to be downloaded, and if it's more
; than the value of this parameter (or if the size is unknown), bfilter will
; drop the connection to the server in order to save some traffic. The default
; value of 15 is good for most people, but if you use a dialup or a GPRS
; connection, you may want to lower it to maybe 8, and if you use a satellite
; connection, you may want to raise it to maybe 40.
save_traffic_threshold=15

; report_client_ip = yes | no | fixed_ip
; Enable reporting the client IP to servers using the X-Forwarded-For header.
report_client_ip=no

; allowed_tunnel_ports = port1, port2, from..to
; Limits the ports for CONNECT requests. Ports allowed by default are
; 443 and 563, which are used for https and nntps respectively.
allowed_tunnel_ports="443, 563"

; cache_size = size_in_megabytes
; BFilter can cache external scripts that it fetches for analyzing.
; This parameter sets the cache size (in megabytes).  To disable caching,
; set cache_size to 0.
cache_size=5
[forwarding]
use_proxy=yes
proxy_type=http
proxy_host=127.0.0.1
proxy_port=8080
Was BFilter running?

People do configure everything and forget to actually start the proxy.

I ran BFilter on XP once. I don't remember any problems.

HTH
Fair question. Well its in my system tray and there's a round dot against the word "Proxy" in the menu, looks running to me. The only other menu option is "Bypass" which would be really useful if it means you can bypass the proxy temporarily. Incidentally, I tried it with Firefox and it still doesn't work.

Currently I'm stuck with Privoxy until someone has a good idea. Maybe its a registry thing or something.
(Apr. 05, 2010 02:01 PM)edwinbradford Wrote: [ -> ]
Code:
[forwarding]
use_proxy=yes
proxy_type=http
proxy_host=127.0.0.1
proxy_port=8080

Try changing
use_proxy=yes
to
use_proxy=no
.

I believe this section is used to 'chain' or 'forward' to another proxy.

HTH
I was hopeful there but sadly it didn't fix it. My IP addresses and DNS servers are all statically configured, I don't know if that makes any difference, can't see why.
Well darn. I installed it.
"yes" or "no" worked for me on Win7 64bit.

So Privoxy and BFilter are set to use the same port.
Privoxy works on 8080.
You exit Privoxy and start BFilter on 8080.
The browser doesn't browse.

Could it be a security issue?
Firewall?
I installed BFilter in my profile's folder rather than the default system folder.

Out of ideas and time, atm.

Sorry
Reference URL's