Post Reply 
Proxomitron Reborn
May. 21, 2018, 02:42 PM (This post was last modified: May. 21, 2018 02:42 PM by ProxRocks.)
Post: #16
RE: Proxomitron Reborn
(May. 21, 2018 08:25 AM)chatterer Wrote:  i can disable weak/insecure cipher-suites ...

do you happen to have a log of where these "weak/insecure" ciphers are encountered?
Add Thank You Quote this message in a reply
May. 21, 2018, 03:16 PM (This post was last modified: May. 21, 2018 03:17 PM by ProxRocks.)
Post: #17
RE: Proxomitron Reborn
limited testing thus far...
WinXP x86 + GreenBrowser 6.9.1223

Help -> About ---
the "copyright" logo only shows up as a "?"
the "based on" is truncated
Scott's last name is not displayed

web site issue ---
will not open .asp web sites
example url = http://www.forwardlook.net/forums/category-view.asp
Add Thank You Quote this message in a reply
May. 21, 2018, 03:41 PM
Post: #18
RE: Proxomitron Reborn
(May. 21, 2018 02:42 PM)ProxRocks Wrote:  
(May. 21, 2018 08:25 AM)chatterer Wrote:  i can disable weak/insecure cipher-suites ...

do you happen to have a log of where these "weak/insecure" ciphers are encountered?

Selftest over Qualys SSL Labs

[Image: Yhjsx2.png]

[Image: oKEW8V.png]

[Image: cBogq9.png]

[Image: efEWVT.png]
Add Thank You Quote this message in a reply
May. 21, 2018, 03:54 PM
Post: #19
RE: Proxomitron Reborn
(May. 21, 2018 12:39 AM)amy Wrote:  
Quote:open proxomitron -> headers -> choose a filter -> cancel
the proxo crash
I could not reproduce this.

In checking, this appears to occur only if a header filter is double-clicked to open the editor. The program crashes when the editor dialog is then exited (whether canceled or OK'd).

The program doesn't crash if the Edit button is used instead.
Add Thank You Quote this message in a reply
May. 21, 2018, 06:48 PM
Post: #20
RE: Proxomitron Reborn
Issues with named variables:

Web Page filters, Test window.
Test Window string = "ptron"

###############
Name = "Test 1"
Active = "FALSE"
Limit = "256"
Match = "$SET(var=_)"
Replace = "$GET(var)"
###############

Ptron4.5J result:
_p_t_r_o_n

Ptron4.5R result:
p

###############
Name = "Test 2"
Active = "FALSE"
Limit = "256"
Match = "$SET(var=)$SET(var=_)"
Replace = "$GET(var)"
###############

Ptron4.5J result:
_p_t_r_o_n

Ptron4.5R result:
ptron

No value is being inserted by the $GET command in either test, but it's particularly odd that the end of the test string in the first test is also being consumed...

Played around with it, and they just kept behaving badly; couldn't really trick 'em into revealing anything else that might be of more help.

Positionals seem well behaved, but I haven't spent much time with those.
Add Thank You Quote this message in a reply
May. 21, 2018, 08:25 PM (This post was last modified: May. 21, 2018 09:08 PM by mizzmona.)
Post: #21
RE: Proxomitron Reborn
Hey Amy, in checking the version info in the resources, 4.5R appears to be a reconstruction of the Beta version of 4.5, as opposed to a rebuild of the final May or June release...so I expect we're going to be finding waaay more bugs and inconsistencies than was originally anticipated. I'm sorry, I know it's bad news. What do you want to do? Push on?

Nevermind... That was in the About, and it was like that in the final. Scott just forgot to change the About verbiage, but he did update the version info in the resource file.

Argh. My bad. Carry on.
Add Thank You Quote this message in a reply
May. 22, 2018, 09:30 AM (This post was last modified: May. 22, 2018 09:33 AM by referrer.)
Post: #22
RE: Proxomitron Reborn
$TYPE(htm) in URL Match didn't work

4.5.1.2R
Win7x86 FirefoxESR52.8.0
Add Thank You Quote this message in a reply
May. 22, 2018, 12:03 PM
Post: #23
RE: Proxomitron Reborn
Thanks for all the bug reports. Released 4.5.1.3 with some more fixes. Keep them coming Thumbs Up
Quote:'Proxo.exe' web page filters are not filtering by default.
Log window, page source, nor 'HTML Debug info' show hits.
However, filtering is enabled for 'HTML Debug info' after $FILTER(1)(^) is added to Bypass.
Could not reproduce this. It is filtering for me.
Quote:It looks like 'Proxo.exe' is failing to consider the '&' conditionals.
Fixed in 4.5.1.3
Quote:<end> may not be working, since 'Restore pop-ups after a page loads' uses it.
Could not reproduce. <end> appends to the end of the page as expected.
Quote:Filter import via right click menu is broken.
Fixed in 4.5.1.3
Quote:sometimes with and sometimes without the proxy
Still could not reproduce this. Will continue working on it.
Quote:Help -> About ---
the "copyright" logo only shows up as a "?"
the "based on" is truncated
Scott's last name is not displayed
Known change from me quickly hacking in a version tag. Will be fixed in final release.
Quote:web site issue ---
will not open .asp web sites
example url = http://www.forwardlook.net/forums/category-view.asp
Site works fine for me.
Quote:Selftest over Qualys SSL Labs
This is because my OpenSSL patch+DLLs enable all ciphers for best compatibility (may make this configurable in future version.)
Quote:In checking, this appears to occur only if a header filter is double-clicked to open the editor. The program crashes when the editor dialog is then exited (whether canceled or OK'd).

The program doesn't crash if the Edit button is used instead.
Fixed in 4.5.1.3
Quote:Issues with named variables
Fixed in 4.5.1.3
Quote:$TYPE(htm) in URL Match didn't work
Fixed in 4.5.1.3. This may be related to everyone else who said all the filters didn't work, so please retest with 4.5.1.3.
Add Thank You Quote this message in a reply
[-] The following 3 users say Thank You to amy for this post:
mizzmona, ProxRocks, chatterer
May. 22, 2018, 02:14 PM
Post: #24
RE: Proxomitron Reborn
(May. 22, 2018 12:03 PM)amy Wrote:  
Quote:web site issue ---
will not open .asp web sites
example url = http://www.forwardlook.net/forums/category-view.asp
Site works fine for me.

4.5.1.3 crashes for me on this .asp web site...
4.5.1.2 did not crash but would not load this .asp web site...


try using sidki_2011-12-22rc1 config + 4.5.1.2...
with that config, at least there is no crash but an Application Error pops up - Exception [C000005] raised in... StartClient::(loop)

the same Application Error pops up while trying to load http://www.google.com
WinXP x86 + IE8 v8.0.6001.18702


now use sidki_2011-12-22rc1 config + 4.5.1.3...
http://www.google.com will now load in IE8...
but the above .asp web site will crash IE8...
Add Thank You Quote this message in a reply
May. 22, 2018, 07:19 PM
Post: #25
RE: Proxomitron Reborn
Blocklist causing crash...

I'm getting a crash on cfg load or upon reloading of a particular blocklist. All I've got at this point is adding "logfile" to the suspect list stops the crashing, but adding any of the "nohash" flags don't. I'm still trying to narrow down what it is exactly that's tripping up ptron inside the file. Will provide further info as soon as I can.
Add Thank You Quote this message in a reply
May. 22, 2018, 11:16 PM (This post was last modified: May. 23, 2018 04:59 AM by mizzmona.)
Post: #26
RE: Proxomitron Reborn
Blocklist crashes program

I think the orig blocklist I was working with has more than one issue, so I'm testing theories with new, smaller lists.

The following blocklist crashes 4.5.1.3 after the program starts, loads the default.cfg, and the main screen's Config button is clicked. I used a default.cfg that had been manually edited to add the blockfile "NadaCaller.txt" to the config under the List name "NadaCaller" (see blockfile, below).

This crasher-blocklist combines calling an undefined, non-existent $LST(Nada) with not using a blocklist keyword.

There is no crash if a defined $LST is called instead. There is also no crash if any blocklist keyword is added in the comment line at the top (NoAddURL, NoHash, NoUrlHash, NoPreHash, junkbuster, or Logfile). Weird.

I recommend starting the program fresh for each test; results were inconsistent for reloaded configs or lists.

The orig blocklist where I first noticed trouble has a keyword (noaddurl), so I've still not figured out why that one crashes everything immediately...but maybe a fix for this will solve that, too. (fingers crossed)

# NadaCaller
#
<p>$LST(Nada)</p>
<b>$LST(Nada)</b>
<u>$LST(Nada)</u>
Add Thank You Quote this message in a reply
May. 23, 2018, 04:10 AM
Post: #27
RE: Proxomitron Reborn
(May. 22, 2018 12:03 PM)amy Wrote:  
Quote:$TYPE(htm) in URL Match didn't work
Fixed in 4.5.1.3. This may be related to everyone else who said all the filters didn't work, so please retest with 4.5.1.3.

4.5.1.3 web filters are working.

HTML Debug info in Opera for prxbx.com/forums/ shows

Code:
HTTP/1.1 200 OK
X-Powered-By: PHP/5.4.45
Set-Cookie: mybb[lastvisit]=1527026527; expires=Thu, 23-May-2019 02:43:03 GMT; path=/forums/;
domain=.prxbx.com
Set-Cookie: mybb[lastactive]=1527043383; expires=Thu, 23-May-2019 02:43:03 GMT; path=/forums/;
domain=.prxbx.com
Set-Cookie: sid=7ba6966f809582e0d18d0c1a7f99e697; path=/forums/; domain=.prxbx.com;
HttpOnly
Content-Type: text/html; charset=UTF-8
Vary: Accept-Encoding
Date: Wed, 23 May 2018 02:43:03 GMT
Accept-Ranges: bytes
Server: LiteSpeed
Connection: close

<!DOCTYPE
<Match: Kill pop-up windows >

before 'proxo.exe' hangs and must be restarted.

Code:
Name = "Kill pop-up windows"
Active = TRUE
URL = "$TYPE(htm)"
Limit = 4096
Match = " (<!DOCTYPE*> |)\1"
Replace = "$STOP()\1\r\n"
          "<!--//--><script src="http://local.ptron/WindowOpen.js"></script>\r\n"

is incorrectly matching the space after <!DOCTYPE because the space character only matches space.
The space character should consume whitespace but always match.

$STOP() routine may be causing the hang.

Quote:If encountered in either the match or replace of a filter $STOP will turn that filter off for the rest of the page/connection. The current match will be allowed to complete, but once that happens, no further matching will be done on that filter.
...
Also note that $STOP will now do its thing even if the filter as a whole doesn't match as long as it's called at some point in the matching process.
Add Thank You Quote this message in a reply
May. 23, 2018, 11:57 AM
Post: #28
RE: Proxomitron Reborn
Quote:4.5.1.3 crashes for me on this .asp web site...
4.5.1.2 did not crash but would not load this .asp web site...


try using sidki_2011-12-22rc1 config + 4.5.1.2...
with that config, at least there is no crash but an Application Error pops up - Exception [C000005] raised in... StartClient::(loop)

the same Application Error pops up while trying to load http://www.google.com
WinXP x86 + IE8 v8.0.6001.18702


now use sidki_2011-12-22rc1 config + 4.5.1.3...
http://www.google.com will now load in IE8...
but the above .asp web site will crash IE8...
Working through this now and fixed a few more bugs, still not 100% yet. I have my own custom set of filters (which probably don't use many of the features) so I hadn't noticed any problems, but I'll go through sidki since it seems far more extensive. I'm able to reproduce those bugs now and will work on fixing them. Keep on posting any more bugs you run into, I won't release 4.5.1.4 yet until sidki is working but appreciate all the reports.
Add Thank You Quote this message in a reply
[-] The following 4 users say Thank You to amy for this post:
ProxRocks, usr, mizzmona, Kye-U
May. 23, 2018, 01:32 PM
Post: #29
RE: Proxomitron Reborn
(May. 23, 2018 11:57 AM)amy Wrote:  I'll go through sidki since it seems far more extensive.
...
I won't release 4.5.1.4 yet until sidki is working but appreciate all the reports.

I thought it might be best to learn how to walk (maybe stand) before we ran... Wink

http://sidki.proxfilter.net/prox/sidki-etc/Techniques.txt

http://sidki.proxfilter.net/prox.html
Add Thank You Quote this message in a reply
[-] The following 1 user says Thank You to JJoe for this post:
mizzmona
May. 24, 2018, 11:23 AM (This post was last modified: May. 25, 2018 06:55 AM by referrer.)
Post: #30
RE: Proxomitron Reborn
The certificate is not trusted because it is self-signed.
(Error code: mozilla_pkix_error_ca_cert_used_as_end_entity)

Get this on every https site(i.e., kakuyomu.jp)
Win7x86 FirefoxESR52.8.0

prefix in config->access not functional(i.e., http://prefix-https..www.google.com)
Add Thank You Quote this message in a reply
Post Reply 


Forum Jump: